Error on Connection Dialog

May 22, 2012 at 11:39 AM
Edited May 22, 2012 at 11:44 AM


   When we entering the details to connect CRM server. It gives an following error.

Error while retrieving Organizations: The remote name could not be resolved: 'dev.*****'

The remote name could not be resolved: 'dev.*****'

The System invalid Operation...........................


like this.


THanks in advance.

May 22, 2012 at 12:16 PM

Could you tell me what were the values you specified (just server name should be enough)?

May 22, 2012 at 12:36 PM

I describe my movements.

Click through 'Loadsitemap', then Create new Connection'.

Connection name:- Crm online access

Checked the option 'Use CRM Online'

Server name:  (also tried:- <orgname>

Selected the option 'Custom Authentication'

Login :- my ms-crm login id

Password:-  my ms-crm password

Then clicked on 'Get Orgs'.

Those errors appears..





May 22, 2012 at 12:41 PM

If i use server name as:


Following errors arise:-

Error while retrieving Organizations:Could not load file or assembly 'Microsft.Identical model, Version -


Finally got an warning message with this:-

WRN:- Assembly Binding Logging Turned Off.

May 22, 2012 at 12:43 PM

I guess you don't have Windows Identity Foundation installed on your computer...

May 22, 2012 at 1:00 PM

Yes. Really I haven't installed in my system. Is there any MS product need to install addtionally?

Anyway I tried to do after WIF isntallation. Come back to you (whatever the result).

This might be helpful to many users.



Thanks your help.

May 22, 2012 at 1:04 PM

It is already mentioned in the Documentation tab of this project page:

May 22, 2012 at 2:14 PM

Yes. Exactly the same issue. But I am not able to install the WIF runtime installation. I've using Windows XP. Then How to overcome this problem? Really the Metadat Document Generator should be a best for CRM amendments.



May 22, 2012 at 2:29 PM

There is no way to use my tools with Windows XP. It is not related to my tools specifically but because of CRM SDK that requires WIF...

Quote from CRM 2011 SDK:

  • Development using the Microsoft Dynamics CRM 2011 assemblies (specifically, Microsoft.Xrm.Sdk.dll) is not supported on Windows XP due to a dependency on Microsoft.IdentityModel.dll. However, you can use the Web Services (WSDL) from XP. For more information, see Use the WSDL Endpoint.
Sep 11, 2012 at 9:47 AM


I get the same error message when trying to connect to CRM Online. I use Windows 7 and WIF is installed too.

Could you, please, help?



Sep 11, 2012 at 9:52 AM

Is this a new CRM Online organization?

If yes, did you tick the checkbox "Use OSDP"?

Sep 11, 2012 at 10:03 PM

I did and got the same error message, just "disco" instead of  "dev".

Sep 13, 2012 at 7:43 AM

ok, it seems the tool does not have the latest connection control embedded. I update it ASAP

Oct 2, 2012 at 2:39 PM

Thank you.

Looking forward to hearing from you.